re = /((\\\\.*\\.*|.*\\)([{]?[0-9A-Fa-f]{8}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{12}[}])?\.(exe|scr|cpl|bat|js|cmd|vbs).*)/m
str = '\\\\localhost\\ADMIN$\\Temp\\RayVentoryPortal\\ndtrack\\mgsreservice.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end