package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Alex\W\(\d+\)$`)
var str = `Alex (52)
Alex 2 (12)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}