$re = '/^Alex\W\(\d+\)$/m';
$str = 'Alex (52)
Alex 2 (12)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);