package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(href|src)="((https*:\/\/)([\w\d\.]+))*\/*([\w\d\/]+)\/*\.(jpg|jpeg|png|gif)"`)
var str = `href="http://example.com/_pu/0/filename.jpg"
href="https://example.com/_pu/0/filename.jpg"
href="/_pu/0/filename.jpg"
href="filename.jpg"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}