const regex = /(href|src)="((https*:\/\/)([\w\d\.]+))*\/*([\w\d\/]+)\/*\.(jpg|jpeg|png|gif)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(href|src)="((https*:\\\/\\\/)([\\w\\d\\.]+))*\\\/*([\\w\\d\\\/]+)\\\/*\\.(jpg|jpeg|png|gif)"', 'gm')
const str = `href="http://example.com/_pu/0/filename.jpg"
href="https://example.com/_pu/0/filename.jpg"
href="/_pu/0/filename.jpg"
href="filename.jpg"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}