#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^A-Z\r\n]*[A-Z])(?=(?:[^\d\r\n]*\d){2})\S{9,15}\$$"
Local $sString = "4hg5Fjkjk$" & @CRLF & _
"" & @CRLF & _
"fh@#Y5fFF5$" & @CRLF & _
"" & @CRLF & _
"hgH5Hu6$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"These should not be valid:" & @CRLF & _
"" & @CRLF & _
"45tyghisu$" & @CRLF & _
"" & @CRLF & _
"5THygfhy$" & @CRLF & _
"" & @CRLF & _
"Gh%hF45$h"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")