$re = '/^(?=[^A-Z\r\n]*[A-Z])(?=(?:[^\d\r\n]*\d){2})\S{9,15}\$$/m';
$str = '4hg5Fjkjk$
fh@#Y5fFF5$
hgH5Hu6$
These should not be valid:
45tyghisu$
5THygfhy$
Gh%hF45$h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);