$re = '/>[\s]*<[^\/]/m';
$str = '<p> 34 df</p> <p> </p>';
$subst = "><";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;