import re
regex = re.compile(r"([A-Za-z]+:)", flags=re.MULTILINE)
test_str = "testing:"
subst = "\"$1\""
result = regex.sub(subst, test_str)
if result:
print(result)