package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]`)
var str = `'
<td>
<button type="button" onclick="viewPrescriber('.$row['ident'].');"></i></button>
</td>'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}