$re = '/"[^"]/';
$str = '\'
<td>
<button type="button" onclick="viewPrescriber(\'.$row[\'ident\'].\');"></i></button>
</td>\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);