using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+(-\d+)?, )*\d+(-\d+)?$";
string input = @"1
1, 4-5
1, 4-5, 8, 11, 13-14
1,,,,
1, 4-5-
1, 4--------2233-----,,,,
1, 2, 3, 4, 5
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}