$re = '/^(\d*[\d.]*?)\.?0*$/m';
$str = '9.25000
11.000
1.02345
2.0300
0.0000
90000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);