import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\<a\\shref)my(?!.*\\<\\/a\\>)";
final String string = "This is a sample my text <a href=\"https://test.com\">test my stuff</a> with my inside <a href=\"https://mytest.com\">test me</a> brackets and my outside brackets oh my . <a href=\"https://test.com\">test my stuff</a> not sure why my instances of my before the last lookahead doesnt work?\n\n"
+ "Intent: I have an FAQ that uses js to highlight words on the page by letter as you type. I need to ignore the HREF entries in the replace function as the injection of a class to highlight the typed letters/words replaced within the HREF messing up the link. \n\n"
+ "Incorrectly Ignoring position 18, 76, 141, 164\n"
+ "Correctly ignoring position 58, 104 and 201\n"
+ "Correctly finding position 227, 242";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}