using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(pxadmin|domain admins|desktop admin|ihisdskadm|matlab_desktopadmin|admindesktokingman|pdidesktop admin|pds_plantdesign_desktop_admin)";
string input = @"desktop admin
pxadmin
domain admins
ihisdskadm
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}