re = /(pxadmin|domain admins|desktop admin|ihisdskadm|matlab_desktopadmin|admindesktokingman|pdidesktop admin|pds_plantdesign_desktop_admin)/
str = 'desktop admin
pxadmin
domain admins
ihisdskadm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end