package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^t(his)`)
var str = `this is a test`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}