use strict;
my $str = 'this is a test';
my $regex = qr/^t(his)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";