$re = '/[0-9]{2}:p[0-9]=[a-zA-Z] [a-zA-Z]( [a-zA-Z]|$)*/m';
$str = '95:p1=a b c 95:p2=d e 96:p1=a b c 96:p2=d e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);