re = /[0-9]{2}:p[0-9]=[a-zA-Z] [a-zA-Z]( [a-zA-Z]|$)*/m
str = '95:p1=a b c 95:p2=d e 96:p1=a b c 96:p2=d e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end