package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.+?\.`)
var str = `jack and jill. went up the hill. to fetch a pail.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}