$re = '/^.+?\./';
$str = 'jack and jill. went up the hill. to fetch a pail.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);