#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^-]*-\s*){2}(.*)"
Local $sString = "The Rational Optimist: How Prosperity Evolves by Matt Ridley /Abundance : The Future Is better Than You Think by Peter Diamonds and Steven Kotler./The Sixth Wave : How to Succeed in a Resource-limited World by James Bradfield Moody and Bianca Nogrady/ What's Mine is Yours: The Rise of Collaborative Consumption by Rachel Botsman and Roo Rogers. - How to Own the World"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")