$re = '/(?:[^-]*-\s*){2}(.*)/m';
$str = 'The Rational Optimist: How Prosperity Evolves by Matt Ridley /Abundance : The Future Is better Than You Think by Peter Diamonds and Steven Kotler./The Sixth Wave : How to Succeed in a Resource-limited World by James Bradfield Moody and Bianca Nogrady/ What\'s Mine is Yours: The Rise of Collaborative Consumption by Rachel Botsman and Roo Rogers. - How to Own the World';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);