#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?!code)\[b\](.*?)\[\/b\](?<!code)"
Local $sString = "[b]bold[/b]" & @CRLF & _
"[code][b]bold[/b][/code]" & @CRLF & _
"[b]bold[/b]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")