$re = '/^(?!code)\[b\](.*?)\[\/b\](?<!code)/';
$str = '[b]bold[/b]
[code][b]bold[/b][/code]
[b]bold[/b]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);