import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){1,3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)";
final String string = "255.255.256.255";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}