re = /((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){1,3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)/m
str = '255.255.256.255'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end