using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*(\d)(?:(\d(?:(\s*;\s*\d*\1)|(\g<2>))\d)|(\g<3>))$";
string input = @"3 ; 3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}