$re = '/^\d*(\d)(?:(\d(?:(\s*;\s*\d*\1)|(\g<2>))\d)|(\g<3>))$/';
$str = '3 ; 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);