const regex = /(?(DEFINE)
(?# var )
(?<var>[a-zA-Z_\x7f-\xff][\w\x7f-\xff]*)
(?# val )
(?<val>(?&call)|(?&str)|(?&num)|(?&bool))
(?<call>\$\{CALL\s+[a-zA-Z_\x7f-\xff][\w\x7f-\xff]*\s*\})
(?<str>"[^"]*"|'[^']*')
(?<num>\d+)
(?<bool>(?i)(?:false|true)(?-i))
)
((?(?=yes\${VAR\s+(?&var)\s*\=\s*(?&val)\s*\}\s)yes|no))
\${(?P<type>VAR)\s+((?&var))\s*\=\s*((?&val))\s*\}(\S)?/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?# var )
(?<var>[a-zA-Z_\\x7f-\\xff][\\w\\x7f-\\xff]*)
(?# val )
(?<val>(?&call)|(?&str)|(?&num)|(?&bool))
(?<call>\\$\\{CALL\\s+[a-zA-Z_\\x7f-\\xff][\\w\\x7f-\\xff]*\\s*\\})
(?<str>"[^"]*"|\'[^\']*\')
(?<num>\\d+)
(?<bool>(?i)(?:false|true)(?-i))
)
((?(?=yes\\${VAR\\s+(?&var)\\s*\\=\\s*(?&val)\\s*\\}\\s)yes|no))
\\${(?P<type>VAR)\\s+((?&var))\\s*\\=\\s*((?&val))\\s*\\}(\\S)?', 'gs')
const str = `
\${VAR foo="What"}x
\${VAR foo="What"}
yes\${VAR foo="What"}
no\${VAR foo="What"}x
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}