re = /(?(DEFINE)
(?# var )
(?<var>[a-zA-Z_\x7f-\xff][\w\x7f-\xff]*)
(?# val )
(?<val>(?&call)|(?&str)|(?&num)|(?&bool))
(?<call>\$\{CALL\s+[a-zA-Z_\x7f-\xff][\w\x7f-\xff]*\s*\})
(?<str>"[^"]*"|'[^']*')
(?<num>\d+)
(?<bool>(?i)(?:false|true)(?-i))
)
((?(?=yes\${VAR\s+(?&var)\s*\=\s*(?&val)\s*\}\s)yes|no))
\${(?P<type>VAR)\s+((?&var))\s*\=\s*((?&val))\s*\}(\S)?/x
str = '
${VAR foo="What"}x
${VAR foo="What"}
yes${VAR foo="What"}
no${VAR foo="What"}x
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end