$re = '/(?=name\d)\V+/';
$str = 'http://server/service/local/repositories/domain/content/name/1.0.0-SNAPSHOT/name2-1.0.0-20161114.174435-142.pom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);