import re
regex = re.compile(r"(?=name\d)\V+")
test_str = "http://server/service/local/repositories/domain/content/name/1.0.0-SNAPSHOT/name2-1.0.0-20161114.174435-142.pom"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")