package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+(_[A-Z]+)*$`)
var str = `THIS_IS_MY_MACRO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}