$re = '/^[A-Z]+(_[A-Z]+)*$/m';
$str = 'THIS_IS_MY_MACRO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);