$re = '/\[{2}{"value":"(.*?)"/m';
$str = '[[{"value":"Site Name"}]]AAAAAAAA[[{"value":"Site Name"}]]BBBB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);