import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*[бвгджзклмнпрстфхцчшщ].*$)";
final String string = "номерок\n"
+ "бочки\n"
+ "еЖ\n"
+ "яД\n"
+ "уХо\n"
+ "Чай\n"
+ "оБои\n"
+ "юЛа\n"
+ "оСа\n"
+ "иВа\n"
+ "яйЦо\n"
+ "оГоНь\n"
+ "ГаГарин\n"
+ "ГиТара\n"
+ "ГайКа\n"
+ "ЖуЧок\n"
+ "ГуБы\n"
+ "ГуаШь\n"
+ "ГуСь\n"
+ "ГВоздь\n"
+ "ГиРя\n"
+ "ДоМ\n"
+ "уТюГ\n"
+ "ДиоД\n"
+ "ДуХи\n"
+ "ДиЧь\n"
+ "ТоПор\n"
+ "ДуШ\n"
+ "ТуЗ\n"
+ "уДаВ\n"
+ "ТеРка\n"
+ "иКоНа\n"
+ "КоЖа\n"
+ "КиТ\n"
+ "КеКс\n"
+ "КоЧан\n"
+ "КуБик\n"
+ "КЛей\n"
+ "КоСа\n"
+ "ХВоя\n"
+ "яКоРь\n"
+ "ЧайНик\n"
+ "ЧуГунок\n"
+ "ЩиТ\n"
+ "оЧКи\n"
+ "ЧуЧело\n"
+ "ЧиП\n"
+ "ЧаШка\n"
+ "ЧаСы\n"
+ "ЩаВель\n"
+ "ЧеРеп\n"
+ "БаяН\n"
+ "ПоГоны\n"
+ "БиТа\n"
+ "ПауК\n"
+ "ПеЧь\n"
+ "ПюПитр\n"
+ "ПиаЛа\n"
+ "БуСы\n"
+ "ПиВо\n"
+ "ПеРо\n"
+ "ШиНа\n"
+ "ЛыЖи\n"
+ "ЛаДья\n"
+ "ЛейКа\n"
+ "ЛуЧ\n"
+ "ЛуПа\n"
+ "ШиЛо\n"
+ "ЛиСа\n"
+ "оЛоВо\n"
+ "ШаР\n"
+ "СаНи\n"
+ "СиГара\n"
+ "СиТо\n"
+ "яЗыК\n"
+ "СаЧок\n"
+ "ЗуБ\n"
+ "СоЛь\n"
+ "СоуС\n"
+ "СейФ\n"
+ "СыР\n"
+ "ФеН\n"
+ "ВаГон\n"
+ "ВаТа\n"
+ "ВаКса\n"
+ "оВоЩ\n"
+ "ВоБла\n"
+ "ВиЛы\n"
+ "ВеСы\n"
+ "ВаФли\n"
+ "ФаРа\n"
+ "РюМка\n"
+ "РоГа\n"
+ "РаДио\n"
+ "РаК\n"
+ "РуЧка\n"
+ "РаПан\n"
+ "РуЛь\n"
+ "РоЗа\n"
+ "аРФа\n"
+ "РаЦия\n"
+ "МаНоМетр\n"
+ "МаНЖет\n"
+ "МоНеТа\n"
+ "МоНоКль\n"
+ "НуНЧаки\n"
+ "МеМБрана\n"
+ "МаНиШка\n"
+ "аНаНаС\n"
+ "НиМФа\n"
+ "НаМоРдник\n"
+ "НоЖНицы\n"
+ "Маленький оЖоГ\n"
+ "НоГТи\n"
+ "НоЖиК\n"
+ "Маленькая ЖуЧка\n"
+ "Маленький ГоБой\n"
+ "аНГеЛ\n"
+ "МаГиСтраль\n"
+ "НоЖоВка\n"
+ "аНГаР\n"
+ "МаяТНик\n"
+ "иНТеГрал\n"
+ "МеДиаТор\n"
+ "иНДиКатор\n"
+ "НиТоЧка\n"
+ "МоТоБлок\n"
+ "МеТЛа\n"
+ "уНиТаЗ\n"
+ "НаДФиль\n"
+ "МеТРо\n"
+ "МуХоМор\n"
+ "Майка КоЖаная\n"
+ "МаКеТ\n"
+ "МаКаКа\n"
+ "Навозная КуЧа\n"
+ "иНКуБатор\n"
+ "МуХоЛовка\n"
+ "МаКСим\n"
+ "МаХоВик\n"
+ "МиКРофон\n"
+ "НоЧНик\n"
+ "Маленький ЧиЖ\n"
+ "МеЧеТь\n"
+ "МяЧиК\n"
+ "Маленькая Чешуйчатая Щука\n"
+ "Набор ЩуПов\n"
+ "МоЧаЛка\n"
+ "НаЧеС\n"
+ "МяЧ Футбольный\n"
+ "Масть ЧеРви\n"
+ "Малиновый ПиоН\n"
+ "Много ПуГовиц\n"
+ "МоПеД\n"
+ "НаБойКи\n"
+ "Новая ПеЧь\n"
+ "Новая ПоБеда\n"
+ "аМПуЛа\n"
+ "НеБоСкреб\n"
+ "Натуральный БиФштекс\n"
+ "НаПеРсток\n"
+ "МеЛьНица\n"
+ "аНаЛьГин\n"
+ "МоЛоТок\n"
+ "МоЛоКо\n"
+ "НаЛиЧник\n"
+ "МоЛьБерт\n"
+ "МыШеЛовка\n"
+ "эМуЛьСия\n"
+ "НаШиВка\n"
+ "МыШЦа\n"
+ "НеЗНайка\n"
+ "МоЗГ\n"
+ "МоСТ\n"
+ "МаСКа\n"
+ "НоСоЧки\n"
+ "НеЗаБудка\n"
+ "НоСиЛки\n"
+ "НаСоС\n"
+ "НаЗВание\n"
+ "НоСоРог\n"
+ "Маленький ВиНтик\n"
+ "Набор ФуЖеров\n"
+ "НеВоД\n"
+ "Нейтральный ФиКсаж\n"
+ "дюйМоВоЧка\n"
+ "аМФиБия\n"
+ "НаВоЛочка\n"
+ "МаВЗолей\n"
+ "Новый ВэФ\n"
+ "аМФоРа\n"
+ "МаРМелад\n"
+ "МоРоЖеное\n"
+ "аМоРТизатор\n"
+ "МоРКовь\n"
+ "НаРуЧники\n"
+ "Медная ЦеПь\n"
+ "МаРЛя\n"
+ "МаРС\n"
+ "МуРаВей\n"
+ "НаРЦис\n"
+ "стол\n"
+ "ГоНГ\n"
+ "оГНеТушитель\n"
+ "ГаМаК\n"
+ "ЖеМЧуг\n"
+ "ГаМБургер\n"
+ "ЖеНьШень\n"
+ "ГНеЗдо\n"
+ "оГНиВо\n"
+ "ГеНеРатор\n"
+ "ГиГаНт\n"
+ "Голодная ГаГа\n"
+ "ЖГуТ\n"
+ "Голубая ГайКа\n"
+ "Желтая ГуЩа\n"
+ "Голубая Губная Помада\n"
+ "ЖиГуЛи\n"
+ "Глиняный ГуСь\n"
+ "Гнутые ГВозди\n"
+ "Голубые ГоРы\n"
+ "ЖеТоН\n"
+ "Железный ДоГ\n"
+ "Глиняная ДуДка\n"
+ "ГаДюКа\n"
+ "Жирная ТоЧка\n"
+ "оГромная ТуБа\n"
+ "ГаДаЛка\n"
+ "Гнутый ДиСк\n"
+ "Желтый ДиВан\n"
+ "ГиДРант\n"
+ "Голубое оКНо\n"
+ "Грубая КоЖа\n"
+ "ЖаКеТ\n"
+ "иГрушечный КоК\n"
+ "Гравийная КуЧа\n"
+ "Железный КаБлук\n"
+ "ЖиКЛер\n"
+ "ГазоноКоСилка\n"
+ "Голубой КоВрик\n"
+ "Географическая КаРта\n"
+ "Железный ЧаН\n"
+ "Жаропрочный ЧуГун\n"
+ "Железная ЩеТка\n"
+ "ЖуЧоК\n"
+ "Голубя ЧуЧело\n"
+ "Железный ЩуП\n"
+ "Железная ЧаШа\n"
+ "Говорящие ЧаСы\n"
+ "Желтый ЩаВель\n"
+ "Желтая ЧеРта\n"
+ "ГиПНоз\n"
+ "Желтая ПоГанка\n"
+ "Желтая ПоДушка\n"
+ "ГуБКа\n"
+ "ГуБаЧ\n"
+ "ГиППопотам\n"
+ "ГоБеЛен\n"
+ "ГиПС\n"
+ "Жигулевское ПиВо\n"
+ "ЖаБРы\n"
+ "ГЛяНцеватель\n"
+ "ГоЛоГрамма\n"
+ "ЖёЛуДь\n"
+ "ГаЛаКтика\n"
+ "ГаЛоЧка\n"
+ "ГЛоБус\n"
+ "ГЛуШитель\n"
+ "ГаЛСтук\n"
+ "ГоЛоВастик\n"
+ "ГаЛеРа\n"
+ "ГуСеНица\n"
+ "Грязная СаЖа\n"
+ "ГаЗеТа\n"
+ "ГаЗиК\n"
+ "Жук уСаЧ\n"
+ "ГаЗоПровод\n"
+ "ЖеЗЛ\n"
+ "одна (1) СоСалка\n"
+ "Железный СиФон\n"
+ "ГаЗиРовка\n"
+ "ГаВаНа\n"
+ "Голубой ФуЖер\n"
+ "ГоВяДина\n"
+ "Газовый ФаКел\n"
+ "ЖВаЧка\n"
+ "Глубинный ВиБратор\n"
+ "Железная ВиЛка\n"
+ "ГВоЗдодер\n"
+ "Глазированные ВаФли\n"
+ "ГВаРдеец\n"
+ "ГРаНата\n"
+ "ГаРаЖ\n"
+ "ГРаДусник\n"
+ "ГиРьКи\n"
+ "ГоРЧица\n"
+ "ГРиБ\n"
+ "ГРеЛка\n"
+ "оГРыЗок\n"
+ "ГРаФин\n"
+ "оГуРеЦ\n"
+ "ДиНаМик\n"
+ "ТоМаГавк\n"
+ "ТеНТ\n"
+ "ТаНК\n"
+ "ТяНуЧка\n"
+ "ТуМБлер\n"
+ "Толстый НоЛь\n"
+ "ДиНоЗавр\n"
+ "ДНеВник\n"
+ "ТоНаР\n"
+ "ДЖиНсы\n"
+ "Длинный ГаГарин\n"
+ "ДоЖДевик\n"
+ "ДЖаКузи\n"
+ "ТяГаЧ\n"
+ "ДЖиП\n"
+ "Два ГоЛубя\n"
+ "ДЖаЗ\n"
+ "ДоГоВор\n"
+ "эТаЖеРка\n"
+ "ДеД-Мороз\n"
+ "Два уТюГа\n"
+ "Два ДиоДа\n"
+ "Длинные ДуХи\n"
+ "ДуДоЧка\n"
+ "Два ТоПора\n"
+ "ДяТеЛ\n"
+ "аТТеСтат\n"
+ "Две уДаВки\n"
+ "ТеТРадь\n"
+ "ТаХоМетр\n"
+ "Деревянная КиЖи\n"
+ "ДиКТофон\n"
+ "Два КеКса\n"
+ "Два КоЧана\n"
+ "ДиКоБраз\n"
+ "оДеКоЛон\n"
+ "ТаКСа\n"
+ "ТыКВа\n"
+ "оТКРывалка\n"
+ "ТаЧаНка\n"
+ "Два ЧуГунка\n"
+ "Деревянный ЩиТ\n"
+ "Деревянный яЩиК\n"
+ "ДоЩеЧки\n"
+ "Два ЧиПа\n"
+ "ТоЧиЛо\n"
+ "Деревянные ЧаСы\n"
+ "ТоЩий Воробей\n"
+ "Древний яЩеР\n"
+ "Туалетная БуМага\n"
+ "Две ПуГовицы\n"
+ "аДаПТер\n"
+ "ТяПКа\n"
+ "ТаПоЧки\n"
+ "Два БоБа\n"
+ "ДиПЛомат\n"
+ "ТуБуС\n"
+ "ДуБовый Веник\n"
+ "ТаБуРет\n"
+ "уДЛиНитель\n"
+ "ТеЛоГрейка\n"
+ "ТеЛеТайп\n"
+ "ТеЛеКамера\n"
+ "уДиЛиЩе\n"
+ "ТеЛеБашня\n"
+ "ДоЛЛар\n"
+ "ТеЛеСкоп\n"
+ "ТеЛеФон\n"
+ "Душ ШаРко\n"
+ "ТеСьМа\n"
+ "Две СиГареты\n"
+ "ТоСТер\n"
+ "ТиСКи\n"
+ "ТыСяЧа\n"
+ "ДСП\n"
+ "ТоСоЛ\n"
+ "Две СоСалки\n"
+ "Толстая СВинья\n"
+ "ДеСеРт\n"
+ "оДуВаНчик\n"
+ "ДВиГатель\n"
+ "оТВеТчик\n"
+ "ТюФяК\n"
+ "ДеВоЧка\n"
+ "Две ВоБлы\n"
+ "ТуФЛи\n"
+ "Два ВеСла\n"
+ "Детская ФуФайка\n"
+ "оТВеРтка\n"
+ "ТуРНик\n"
+ "ДиРиЖабль\n"
+ "ТоРТ\n"
+ "ТаРаКан\n"
+ "ТРеЩотка\n"
+ "ТРуБа\n"
+ "ДРеЛь\n"
+ "ТРуСы\n"
+ "ДеРеВо\n"
+ "ТеРРорист\n"
+ "КаМиН\n"
+ "КНиГа\n"
+ "КоНДенсатор\n"
+ "КоНьКи\n"
+ "КуМаЧ\n"
+ "КНоПка\n"
+ "КаМыШ\n"
+ "КаНиСтра\n"
+ "КоНФета\n"
+ "КаМеРтон\n"
+ "КоЖаНка\n"
+ "Красная ЖиЖа\n"
+ "КоГоТь\n"
+ "КоЖуХ\n"
+ "число пи\n"
+ "КГБ\n"
+ "КеГЛя\n"
+ "Красивый ЖаСмин\n"
+ "три (3) ГВоздя\n"
+ "КоЖуРа\n"
+ "ХиТиН\n"
+ "Хот-ДоГ\n"
+ "КаТоД\n"
+ "ХоДиКи\n"
+ "КеТЧуп\n"
+ "КаТаПульта\n"
+ "КаТуШка\n"
+ "КуТуЗов\n"
+ "КаТаФалк\n"
+ "КаТеР\n"
+ "аККуМулятор\n"
+ "три (3) КеГли\n"
+ "КаКТус\n"
+ "КоКа-Кола\n"
+ "Компостная КуЧа\n"
+ "Красные КуБики\n"
+ "КуКЛа\n"
+ "КоКоС\n"
+ "Крепкий КоФе\n"
+ "аККоРдеон\n"
+ "ХиЩНик\n"
+ "три (3) ЧиЖа\n"
+ "КоЧеТ\n"
+ "КауЧуК\n"
+ "три (3) ЧуЧело\n"
+ "ХаЧаПури\n"
+ "КаЧеЛи\n"
+ "Калькулятор-ЧаСы\n"
+ "Крепкий ЧиФир\n"
+ "КоЧеРга\n"
+ "КаБиНа\n"
+ "три (3) БоГатыря\n"
+ "КиПяТильник\n"
+ "КаПКан\n"
+ "КаБаЧок\n"
+ "три (3) ПиПетки\n"
+ "КаПюШон\n"
+ "КаПСула\n"
+ "Кружка ПиВа\n"
+ "КоБуРа\n"
+ "КаЛеНдарь\n"
+ "КоЛГейт\n"
+ "КаЛиТка\n"
+ "КаЛьКулятор\n"
+ "КЛюЧи\n"
+ "ХЛеБ\n"
+ "КЛюШка\n"
+ "КЛиЗма\n"
+ "КЛеВер\n"
+ "КЛаРнет\n"
+ "КоСМетичка\n"
+ "три (3) СиГареты\n"
+ "КаСТрюля\n"
+ "КаСКа\n"
+ "КуСаЧки\n"
+ "Красная ЗиПпо\n"
+ "КоЗеЛ\n"
+ "КаССета\n"
+ "КуЗоВ\n"
+ "Коробочка СыРа\n"
+ "КоФейНик\n"
+ "Красный ФуЖер\n"
+ "КюВеТа\n"
+ "КВаКер\n"
+ "ХВоЩ\n"
+ "КоВБойка\n"
+ "КоВШ\n"
+ "КВаС\n"
+ "КоФеВарка\n"
+ "аКВаРель\n"
+ "КоРоНа\n"
+ "КРуЖка\n"
+ "КоРыТо\n"
+ "КРоКодил\n"
+ "КРюЧок\n"
+ "КРаБ\n"
+ "КРыШка\n"
+ "КРеСт\n"
+ "КРеВетка\n"
+ "КоРиЦа\n"
+ "Черная МиНа\n"
+ "Четыре НоГи\n"
+ "ЧеМоДан\n"
+ "ЩеНоК\n"
+ "Черный МяЧ\n"
+ "ЧеМПион\n"
+ "Четыре МеЛка\n"
+ "Черные НоСки\n"
+ "Черный НаВигатор\n"
+ "ЧайНиЦа\n"
+ "ЧуГуН\n"
+ "Четыре ЖГута\n"
+ "Черный ГуТалин\n"
+ "Четыре ГайКи\n"
+ "Четыре ЖуЧка\n"
+ "Черная ЖаБа\n"
+ "ЩеГоЛ\n"
+ "Черный ГуСь\n"
+ "Четыре ГВоздики\n"
+ "Чайный ГРиб\n"
+ "ЩеТиНа\n"
+ "Черный ДоГ\n"
+ "Четыре ДиоДа\n"
+ "ЧёТКи\n"
+ "ЩёТоЧка\n"
+ "Черный ДюБель\n"
+ "уЧиТеЛь\n"
+ "ЧуДеСа\n"
+ "ЧеснокоДаВка\n"
+ "ЧаДРа\n"
+ "ЧеКаНка\n"
+ "ЧиКаГо\n"
+ "ЧуКоТка\n"
+ "Четыре КаКтуса\n"
+ "ЧуКЧа\n"
+ "Черный КуБ\n"
+ "ЧеХоЛ\n"
+ "ЧеКиСт\n"
+ "ЧеХоВ\n"
+ "ЧаКРа\n"
+ "оЧеЧНик\n"
+ "оЧиЩенные оГурцы\n"
+ "ЧеЧеТка\n"
+ "ЩёЧКи\n"
+ "Ча-Ча-Ча\n"
+ "Четыре ЩеПки\n"
+ "ЧуЧеЛо\n"
+ "Четверть ЧаСа\n"
+ "оЧиЩенные Фрукты\n"
+ "Черный ЧеРеп\n"
+ "Черный БаНан\n"
+ "Черный БеГемот\n"
+ "ЩеПоТка\n"
+ "ЩеПКа\n"
+ "ЩиПЧики\n"
+ "Читальный аППарат\n"
+ "ЩуПаЛьце\n"
+ "ЧиПСы\n"
+ "ЧаПаеВ\n"
+ "ЧеБуРашка\n"
+ "ЧеЛНок\n"
+ "Чайная ЛоЖка\n"
+ "ЧаЛДа\n"
+ "ЧуЛКи\n"
+ "ЩеЛоЧь\n"
+ "ЩеЛБан\n"
+ "Черная ШеЛковица\n"
+ "ЧеЛюСть\n"
+ "ЧеЛоВек\n"
+ "Чугунный ШаР\n"
+ "ЧеСНок\n"
+ "Четыре СиГары\n"
+ "ЧаСТокол\n"
+ "ЧаСиКи\n"
+ "Черный СыЧ\n"
+ "ЧиЗБургер\n"
+ "ЧиСЛо\n"
+ "Чесночный СоуС\n"
+ "ЧаСоВня\n"
+ "Черный ЗаяЦ\n"
+ "Черный ФоНарь\n"
+ "Черная ФиГура\n"
+ "Чистая ВоДа\n"
+ "Черный ВыКлючатель\n"
+ "Чистые ВеЩи\n"
+ "Черный эФиоП\n"
+ "ЩаВеЛь\n"
+ "Черная ВиЗитка\n"
+ "Черные Вязаные Варежки\n"
+ "Черничное ВаРенье\n"
+ "ЧеРНила\n"
+ "Четыре РоГа\n"
+ "ЧеРТ\n"
+ "ЧиРКалка\n"
+ "ЧеРЧение\n"
+ "ЧеРеПаха\n"
+ "ЧеРеШня\n"
+ "Черная РоЗа\n"
+ "ЧеРВяк\n"
+ "яЩеРиЦа\n"
+ "БаНаН\n"
+ "ПиНГвин\n"
+ "ПоМиДор\n"
+ "БиНоКль\n"
+ "БаНоЧка\n"
+ "БоМБа\n"
+ "ПеНаЛ\n"
+ "ПеМЗа\n"
+ "БМВ\n"
+ "БуМеРанг\n"
+ "ПиЖаМа\n"
+ "БаГаЖник\n"
+ "БиГуДи\n"
+ "Пятнистый ЖуК\n"
+ "ПуГаЧ\n"
+ "Белая ЖаБа\n"
+ "ПуГаЛо\n"
+ "ПеГаС\n"
+ "ПуГоВица\n"
+ "аБаЖуР\n"
+ "ПауТиНа\n"
+ "ПиДЖак\n"
+ "ПоДДон\n"
+ "ПяТКа\n"
+ "ПяТаЧок\n"
+ "ПоДПора\n"
+ "БуТыЛка\n"
+ "ПоДСтаканник\n"
+ "ПаТеФон\n"
+ "ПуДРа\n"
+ "ПиКНик\n"
+ "БуХГалтерия\n"
+ "оБъеКТив\n"
+ "ПиККоло\n"
+ "Бессмертный КоЩей\n"
+ "ПиКаП\n"
+ "ПаКЛя\n"
+ "БоКС\n"
+ "БуКВы\n"
+ "БеКаР\n"
+ "ПеЧеНье\n"
+ "ПиЧуГа\n"
+ "ПеЧаТь\n"
+ "БаЧоК\n"
+ "Полосатое ЧуЧело\n"
+ "Белый ЧеБурек\n"
+ "ПЧеЛы\n"
+ "Полосатые ЧаСы\n"
+ "БеЧёВка\n"
+ "ПеЩеРа\n"
+ "БуБеН\n"
+ "ПоПуГай\n"
+ "ПиПеТка\n"
+ "ПаПКа\n"
+ "БаБоЧка\n"
+ "БаоБаБ\n"
+ "ПеПеЛьница\n"
+ "ПаПуаС\n"
+ "ПуПоВина\n"
+ "ПаПоРотник\n"
+ "ПаяЛьНик\n"
+ "ПЛуГ\n"
+ "ПаЛаТка\n"
+ "ПуШКа\n"
+ "ПаЛаЧ\n"
+ "ПоЛиП\n"
+ "БаЛаЛайка\n"
+ "ПЛаСтилин\n"
+ "ПоЛоВник\n"
+ "ПаЛеЦ\n"
+ "ПиСьМо\n"
+ "ПейЗаЖ\n"
+ "ПиСТолет\n"
+ "БаСКетбол\n"
+ "ПеСоЧница\n"
+ "ПаСПорт\n"
+ "ПьеЗоэЛемент\n"
+ "ПиССуар\n"
+ "ПоЗВоночник\n"
+ "ПуЗыРь\n"
+ "БиВеНь\n"
+ "Полосатый ВаГон\n"
+ "ПоВоДок\n"
+ "ПуФиК\n"
+ "Полоски оВоЩные\n"
+ "ПиВБар\n"
+ "ПаВЛин\n"
+ "ПоВяЗка\n"
+ "ПиВоВар\n"
+ "ПеВеЦ\n"
+ "ПиРаМида\n"
+ "ПРуЖина\n"
+ "ПРоТивогаз\n"
+ "ПаРиК\n"
+ "ПРиЩепка\n"
+ "БаРаБан\n"
+ "ПаРаШют\n"
+ "ПаРуС\n"
+ "БРеВно\n"
+ "ПеРеЦ\n"
+ "ЛиМоН\n"
+ "ЛиНГафон\n"
+ "ЛаНДыш\n"
+ "ЛиНейКа\n"
+ "Шипованный МяЧ\n"
+ "ЛаМПа\n"
+ "ШиНеЛь\n"
+ "аЛМаЗ\n"
+ "ЛеНиВец\n"
+ "ШНуРок\n"
+ "ШаГоМер\n"
+ "ЛеГкая Гирька\n"
+ "ЛоГоТип\n"
+ "ЛоЖКа\n"
+ "ЛеГоЧница\n"
+ "аЛГеБра\n"
+ "ЛяГуШка\n"
+ "ЛоГиСтика\n"
+ "ЛеГаВая\n"
+ "ЛаГеРь\n"
+ "ШТаНга\n"
+ "ЛеДоГенератор\n"
+ "ШТаТив\n"
+ "уЛиТКа\n"
+ "ЛоДоЧка\n"
+ "ШТоПор\n"
+ "ЛаДоШи\n"
+ "ЛоТоС\n"
+ "ШеДеВр\n"
+ "ШТуРвал\n"
+ "ШаХМаты\n"
+ "аЛКоГоль\n"
+ "ЛоКаТор\n"
+ "Широкая КойКа\n"
+ "ЛиХаЧ\n"
+ "ЛейКоПластырь\n"
+ "ШоКоЛад\n"
+ "эЛиКСир\n"
+ "ШКаФ\n"
+ "ШКуРка\n"
+ "ЛуЧиНа\n"
+ "ЛаЧуГа\n"
+ "эЛектрическая ЩеТка\n"
+ "ШаеЧКа\n"
+ "Лесная ЧаЩа\n"
+ "эЛектрический ЩуП\n"
+ "Широкая ЩеЛь\n"
+ "Люминесцентные ЧаСы\n"
+ "ЛеЧебная Вода\n"
+ "Ленточный ЧеРвь\n"
+ "аЛьБоМ\n"
+ "ШПаГа\n"
+ "ЛоПаТа\n"
+ "ЛоПуХ\n"
+ "ШаПоЧка\n"
+ "Школьная ПаПка\n"
+ "ШПиЛь\n"
+ "ЛоБЗик\n"
+ "ЛюБоВь\n"
+ "ШПРиц\n"
+ "ШЛеМ\n"
+ "ШЛаГбаум\n"
+ "ЛоШаДь\n"
+ "ШиШКа\n"
+ "Лазерный ЛуЧ\n"
+ "ШЛюПка\n"
+ "ШаШЛык\n"
+ "иЛЛюЗия\n"
+ "ШЛейФ\n"
+ "ШуЛеР\n"
+ "ЛеСеНка\n"
+ "ЛеЗГинка\n"
+ "ЛюСТра\n"
+ "ЛеСКа\n"
+ "ЛиСиЧка\n"
+ "Широкое СоПло\n"
+ "оЛовянный СоЛдатик\n"
+ "ЛаССо\n"
+ "ЛеЗВие\n"
+ "ЛаЗеР\n"
+ "ЛаВиНа\n"
+ "ШВейная иГла\n"
+ "ЛиФТ\n"
+ "ЛаВКа\n"
+ "ЛиФЧик\n"
+ "ШВаБра\n"
+ "ЛаВаШ\n"
+ "Широкая ВаЗа\n"
+ "Шоколадные ВаФли\n"
+ "ШиФР\n"
+ "ШаРНир\n"
+ "ШаРЖ\n"
+ "ШоРТы\n"
+ "ШаРиК\n"
+ "ЛаРЧик\n"
+ "ШуРуП\n"
+ "ШеРШень\n"
+ "ШеРСть\n"
+ "ШаРФ\n"
+ "Штанген-ЦиРкуль\n"
+ "оСьМиНог\n"
+ "СНеЖинка\n"
+ "ЗоНТ\n"
+ "СуМКа\n"
+ "СМыЧок\n"
+ "СоМБреро\n"
+ "СаМоЛет\n"
+ "ЗаМаЗка\n"
+ "СаМоВар\n"
+ "СМоРодина\n"
+ "ЗаЖиМ\n"
+ "ЗаЖиГалка\n"
+ "ЗаГоТовка\n"
+ "СайГаК\n"
+ "СГуЩенка\n"
+ "иЗГиБ\n"
+ "ЗаГЛушка\n"
+ "ЗаГС\n"
+ "ЗаГоВор\n"
+ "СиГаРеты\n"
+ "СТаНок\n"
+ "СТоГ\n"
+ "СТаТуэтка\n"
+ "СТаКан\n"
+ "ЗаТоЧка\n"
+ "СТоП\n"
+ "СТуЛ\n"
+ "СаДиСт\n"
+ "СТаВни\n"
+ "СТРекоза\n"
+ "СеКуНдомер\n"
+ "Старая ХиЖина\n"
+ "СКаТ\n"
+ "СКаКалка\n"
+ "СеКаЧ\n"
+ "СКоБа\n"
+ "СКаЛка\n"
+ "СаКСофон\n"
+ "СКоВорода\n"
+ "СКРипка\n"
+ "ЗайЧоНок\n"
+ "СыЧуГ\n"
+ "СЧеТы\n"
+ "СуЧоК\n"
+ "СЧетЧик\n"
+ "Соли ЩеПотка\n"
+ "ЗаЩеЛка\n"
+ "ЗубоЧиСтки\n"
+ "СоЧиВо\n"
+ "ЗаЧаРованные\n"
+ "ЗаПоНка\n"
+ "СаПоГи\n"
+ "СПуТник\n"
+ "аЗБуКа\n"
+ "СПиЧки\n"
+ "СуППорт\n"
+ "ЗуБиЛо\n"
+ "ЗаПиСка\n"
+ "СаПФир\n"
+ "ЗаБоР\n"
+ "СЛоН\n"
+ "ЗаЛоГ\n"
+ "СЛайД\n"
+ "СуШКа\n"
+ "иЗЛуЧатель\n"
+ "СаЛьПа\n"
+ "СуШиЛка\n"
+ "СиЛоС\n"
+ "СЛиВа\n"
+ "иЗоЛяЦия\n"
+ "СоСНа\n"
+ "Снежный СуГроб\n"
+ "ЗаСТежка\n"
+ "СоСКа\n"
+ "СоСоЧек\n"
+ "Золотые ЗуБы\n"
+ "СоСуЛьки\n"
+ "СоСиСки\n"
+ "ЗаСоВ\n"
+ "ЗаЗоР\n"
+ "ЗВоНок\n"
+ "оСВеЖитель\n"
+ "СВеТофор\n"
+ "СВеКла\n"
+ "СВеЧа\n"
+ "СВоБода\n"
+ "СуФЛе\n"
+ "СВиСток\n"
+ "ЗаВиВка\n"
+ "СВеРло\n"
+ "СиРеНа\n"
+ "СеРьГа\n"
+ "СеРДце\n"
+ "ЗеРКало\n"
+ "СоРоЧка\n"
+ "СеРП\n"
+ "оСЦиЛлограф\n"
+ "СРеЗ\n"
+ "СеРВант\n"
+ "Стационарная РаЦия\n"
+ "ВаННа\n"
+ "ВиНоГрад\n"
+ "ВеНТилятор\n"
+ "ВеНиК\n"
+ "ВеНЧик\n"
+ "ВаМПир\n"
+ "ФиНиШ\n"
+ "ВНиЗ\n"
+ "ФаНФара\n"
+ "ФоНаРь\n"
+ "ВаГоНетка\n"
+ "ВыЖиГатель\n"
+ "ФаГоТ\n"
+ "Винт с ГайКой\n"
+ "коФейная ГуЩа\n"
+ "Винный ЖБан\n"
+ "Вареный ЖеЛток\n"
+ "ФуГаС\n"
+ "ВиГВам\n"
+ "ФиГуРы\n"
+ "аВТоМат\n"
+ "ФоТоГрафия\n"
+ "ФоТоТаймер\n"
+ "аВТоКар\n"
+ "ВеТоЧка\n"
+ "ФуТБолка\n"
+ "ФуТЛяр\n"
+ "Виниловый ДиСк\n"
+ "Фруктовый ТВорожок\n"
+ "ВеДРо\n"
+ "ФотоКаМера\n"
+ "8 кг\n"
+ "ВыХоД\n"
+ "Воздушная КуКуруза\n"
+ "Высокие КаЧели\n"
+ "Вельветовая КеПка\n"
+ "ФаКеЛ\n"
+ "ФоКуС\n"
+ "Вязаная КоФта\n"
+ "ВаКЦина\n"
+ "Фарфоровый ЧайНик\n"
+ "ВеЧный оГонь\n"
+ "ВеЧный Двигатель\n"
+ "оВеЧКа\n"
+ "Филина ЧуЧело\n"
+ "Фигурные ЧиПсы\n"
+ "Вязаный ЧуЛок\n"
+ "оВоЩеСушилка\n"
+ "Вареный ЩаВель\n"
+ "оВоЩеРезка\n"
+ "ФотоБуМага\n"
+ "Вязаная ПуГовица\n"
+ "Велосипедная ПеДаль\n"
+ "Винни-ПуХ\n"
+ "ВыПеЧка\n"
+ "ФотоаППарат\n"
+ "ФотоПЛенка\n"
+ "ВыПиСка\n"
+ "Высокий ПуФик\n"
+ "ФБР\n"
+ "ВоЛаН\n"
+ "ФЛаГ\n"
+ "ФиЛьТр\n"
+ "ВаЛиК\n"
+ "ВоЛЧок\n"
+ "ФотоаЛьБом\n"
+ "ВеШаЛка\n"
+ "ВеЛоСипед\n"
+ "ВоЛьВо\n"
+ "Воздушный ШаР\n"
+ "ВаЗоН\n"
+ "оВСюГ\n"
+ "ВъеЗД\n"
+ "ФиЗиКа\n"
+ "ВаЗоЧка\n"
+ "ВСПышка\n"
+ "ФаСоЛь\n"
+ "ФоССа\n"
+ "ФоСФор\n"
+ "ВиЗиР\n"
+ "Виноградное ВиНо\n"
+ "Восковая ФиГура\n"
+ "Воздушная ВаТа\n"
+ "ВыВиХ\n"
+ "Вареные оВоЩи\n"
+ "Вяленая ВоБла\n"
+ "ВаФеЛьница\n"
+ "ВыВеСка\n"
+ "три восьмерки\n"
+ "ВВЦ\n"
+ "ФаРаоН\n"
+ "ФуРаЖка\n"
+ "ВеРТолет\n"
+ "аФРиКа\n"
+ "ВРаЧ\n"
+ "ВеРБлюд\n"
+ "ФаРШ\n"
+ "ФеРЗь\n"
+ "ВеРеВка\n"
+ "аВРоРа\n"
+ "РеМеНь\n"
+ "РиНГ\n"
+ "аРМаТура\n"
+ "РаМКа\n"
+ "РаНЧо\n"
+ "РоМБ\n"
+ "РоМаШка\n"
+ "оРужейное МаСло\n"
+ "ЦиНоВка\n"
+ "РаНеЦ\n"
+ "аРГаМак\n"
+ "РоГоЖа\n"
+ "РоГаТка\n"
+ "РоЖоК\n"
+ "РоГаЧ\n"
+ "РеГБи\n"
+ "иеРоГЛиф\n"
+ "ленин\n"
+ "РЖаВчина\n"
+ "РоЖиЦа\n"
+ "оРДеН\n"
+ "РаДуГа\n"
+ "РаДиаТор\n"
+ "РеДьКа\n"
+ "РадиоТоЧка\n"
+ "Резиновая ДуБинка\n"
+ "РеТуШь\n"
+ "РеДиСка\n"
+ "аРТеФакт\n"
+ "РаДаР\n"
+ "РуКоМойник\n"
+ "Рваная КоЖа\n"
+ "РаКеТа\n"
+ "оРеХоКол\n"
+ "Розовые КаЧели\n"
+ "РуКоПись\n"
+ "ЦиКЛя\n"
+ "РюКЗак\n"
+ "РаКоВина\n"
+ "РеКоРд\n"
+ "РуЧНой (эспандер)\n"
+ "РыЧаГ\n"
+ "Резиновая ЩеТка\n"
+ "РуЧКа\n"
+ "Румяные ЩеЧки\n"
+ "Розовый ЧеПчик\n"
+ "Русская ЧаШа\n"
+ "РадиоЧаСы\n"
+ "РуЧной Фонарик\n"
+ "РуЧной Радар\n"
+ "РуБаНок\n"
+ "Рукав ПоЖарный\n"
+ "РоБоТ\n"
+ "РыБКа\n"
+ "РяБЧик\n"
+ "Ром-БаБа\n"
+ "аРБаЛет\n"
+ "аРБуЗ\n"
+ "Разливное ПиВо\n"
+ "РуПоР\n"
+ "ЦиЛиНдр\n"
+ "Цветочный ЛуГ\n"
+ "РуЛеТка\n"
+ "РоЛиКи\n"
+ "Цилиндр и ЛиЧинка\n"
+ "РаШПиль\n"
+ "Резиновый ШЛанг\n"
+ "РеЛьСы\n"
+ "РеЛьеФ\n"
+ "Розовый ШаРик\n"
+ "РеСНицы\n"
+ "РоЗГи\n"
+ "РоЗеТка\n"
+ "иРиСКи\n"
+ "РоЗоЧка\n"
+ "РеСПиратор\n"
+ "РуСаЛка\n"
+ "РеЗиСтор\n"
+ "РейСФедер\n"
+ "РеЗеЦ\n"
+ "РеВуН\n"
+ "Цветные ФиГуры\n"
+ "ЦВеТок\n"
+ "РаФиК\n"
+ "Розовая оВЧина\n"
+ "РиФленая Бумага\n"
+ "РеФЛектор\n"
+ "Цифровые ВеСы\n"
+ "ЦВетной Фартук\n"
+ "ЦиФеРблат\n"
+ "оРанжевая уРНа\n"
+ "оРанжевая оРиГами\n"
+ "аРаРаТ\n"
+ "ЦиРКуль\n"
+ "Цветные РуЧки\n"
+ "РеЦеПт\n"
+ "РоРШах\n"
+ "Ржавая ЦиСтерна\n"
+ "ЦаРеВна\n"
+ "РыЦаРь\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}