// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*[бвгджзклмнпрстфхцчшщ].*$)").unwrap();
let string = "номерок
бочки
еЖ
яД
уХо
Чай
оБои
юЛа
оСа
иВа
яйЦо
оГоНь
ГаГарин
ГиТара
ГайКа
ЖуЧок
ГуБы
ГуаШь
ГуСь
ГВоздь
ГиРя
ДоМ
уТюГ
ДиоД
ДуХи
ДиЧь
ТоПор
ДуШ
ТуЗ
уДаВ
ТеРка
иКоНа
КоЖа
КиТ
КеКс
КоЧан
КуБик
КЛей
КоСа
ХВоя
яКоРь
ЧайНик
ЧуГунок
ЩиТ
оЧКи
ЧуЧело
ЧиП
ЧаШка
ЧаСы
ЩаВель
ЧеРеп
БаяН
ПоГоны
БиТа
ПауК
ПеЧь
ПюПитр
ПиаЛа
БуСы
ПиВо
ПеРо
ШиНа
ЛыЖи
ЛаДья
ЛейКа
ЛуЧ
ЛуПа
ШиЛо
ЛиСа
оЛоВо
ШаР
СаНи
СиГара
СиТо
яЗыК
СаЧок
ЗуБ
СоЛь
СоуС
СейФ
СыР
ФеН
ВаГон
ВаТа
ВаКса
оВоЩ
ВоБла
ВиЛы
ВеСы
ВаФли
ФаРа
РюМка
РоГа
РаДио
РаК
РуЧка
РаПан
РуЛь
РоЗа
аРФа
РаЦия
МаНоМетр
МаНЖет
МоНеТа
МоНоКль
НуНЧаки
МеМБрана
МаНиШка
аНаНаС
НиМФа
НаМоРдник
НоЖНицы
Маленький оЖоГ
НоГТи
НоЖиК
Маленькая ЖуЧка
Маленький ГоБой
аНГеЛ
МаГиСтраль
НоЖоВка
аНГаР
МаяТНик
иНТеГрал
МеДиаТор
иНДиКатор
НиТоЧка
МоТоБлок
МеТЛа
уНиТаЗ
НаДФиль
МеТРо
МуХоМор
Майка КоЖаная
МаКеТ
МаКаКа
Навозная КуЧа
иНКуБатор
МуХоЛовка
МаКСим
МаХоВик
МиКРофон
НоЧНик
Маленький ЧиЖ
МеЧеТь
МяЧиК
Маленькая Чешуйчатая Щука
Набор ЩуПов
МоЧаЛка
НаЧеС
МяЧ Футбольный
Масть ЧеРви
Малиновый ПиоН
Много ПуГовиц
МоПеД
НаБойКи
Новая ПеЧь
Новая ПоБеда
аМПуЛа
НеБоСкреб
Натуральный БиФштекс
НаПеРсток
МеЛьНица
аНаЛьГин
МоЛоТок
МоЛоКо
НаЛиЧник
МоЛьБерт
МыШеЛовка
эМуЛьСия
НаШиВка
МыШЦа
НеЗНайка
МоЗГ
МоСТ
МаСКа
НоСоЧки
НеЗаБудка
НоСиЛки
НаСоС
НаЗВание
НоСоРог
Маленький ВиНтик
Набор ФуЖеров
НеВоД
Нейтральный ФиКсаж
дюйМоВоЧка
аМФиБия
НаВоЛочка
МаВЗолей
Новый ВэФ
аМФоРа
МаРМелад
МоРоЖеное
аМоРТизатор
МоРКовь
НаРуЧники
Медная ЦеПь
МаРЛя
МаРС
МуРаВей
НаРЦис
стол
ГоНГ
оГНеТушитель
ГаМаК
ЖеМЧуг
ГаМБургер
ЖеНьШень
ГНеЗдо
оГНиВо
ГеНеРатор
ГиГаНт
Голодная ГаГа
ЖГуТ
Голубая ГайКа
Желтая ГуЩа
Голубая Губная Помада
ЖиГуЛи
Глиняный ГуСь
Гнутые ГВозди
Голубые ГоРы
ЖеТоН
Железный ДоГ
Глиняная ДуДка
ГаДюКа
Жирная ТоЧка
оГромная ТуБа
ГаДаЛка
Гнутый ДиСк
Желтый ДиВан
ГиДРант
Голубое оКНо
Грубая КоЖа
ЖаКеТ
иГрушечный КоК
Гравийная КуЧа
Железный КаБлук
ЖиКЛер
ГазоноКоСилка
Голубой КоВрик
Географическая КаРта
Железный ЧаН
Жаропрочный ЧуГун
Железная ЩеТка
ЖуЧоК
Голубя ЧуЧело
Железный ЩуП
Железная ЧаШа
Говорящие ЧаСы
Желтый ЩаВель
Желтая ЧеРта
ГиПНоз
Желтая ПоГанка
Желтая ПоДушка
ГуБКа
ГуБаЧ
ГиППопотам
ГоБеЛен
ГиПС
Жигулевское ПиВо
ЖаБРы
ГЛяНцеватель
ГоЛоГрамма
ЖёЛуДь
ГаЛаКтика
ГаЛоЧка
ГЛоБус
ГЛуШитель
ГаЛСтук
ГоЛоВастик
ГаЛеРа
ГуСеНица
Грязная СаЖа
ГаЗеТа
ГаЗиК
Жук уСаЧ
ГаЗоПровод
ЖеЗЛ
одна (1) СоСалка
Железный СиФон
ГаЗиРовка
ГаВаНа
Голубой ФуЖер
ГоВяДина
Газовый ФаКел
ЖВаЧка
Глубинный ВиБратор
Железная ВиЛка
ГВоЗдодер
Глазированные ВаФли
ГВаРдеец
ГРаНата
ГаРаЖ
ГРаДусник
ГиРьКи
ГоРЧица
ГРиБ
ГРеЛка
оГРыЗок
ГРаФин
оГуРеЦ
ДиНаМик
ТоМаГавк
ТеНТ
ТаНК
ТяНуЧка
ТуМБлер
Толстый НоЛь
ДиНоЗавр
ДНеВник
ТоНаР
ДЖиНсы
Длинный ГаГарин
ДоЖДевик
ДЖаКузи
ТяГаЧ
ДЖиП
Два ГоЛубя
ДЖаЗ
ДоГоВор
эТаЖеРка
ДеД-Мороз
Два уТюГа
Два ДиоДа
Длинные ДуХи
ДуДоЧка
Два ТоПора
ДяТеЛ
аТТеСтат
Две уДаВки
ТеТРадь
ТаХоМетр
Деревянная КиЖи
ДиКТофон
Два КеКса
Два КоЧана
ДиКоБраз
оДеКоЛон
ТаКСа
ТыКВа
оТКРывалка
ТаЧаНка
Два ЧуГунка
Деревянный ЩиТ
Деревянный яЩиК
ДоЩеЧки
Два ЧиПа
ТоЧиЛо
Деревянные ЧаСы
ТоЩий Воробей
Древний яЩеР
Туалетная БуМага
Две ПуГовицы
аДаПТер
ТяПКа
ТаПоЧки
Два БоБа
ДиПЛомат
ТуБуС
ДуБовый Веник
ТаБуРет
уДЛиНитель
ТеЛоГрейка
ТеЛеТайп
ТеЛеКамера
уДиЛиЩе
ТеЛеБашня
ДоЛЛар
ТеЛеСкоп
ТеЛеФон
Душ ШаРко
ТеСьМа
Две СиГареты
ТоСТер
ТиСКи
ТыСяЧа
ДСП
ТоСоЛ
Две СоСалки
Толстая СВинья
ДеСеРт
оДуВаНчик
ДВиГатель
оТВеТчик
ТюФяК
ДеВоЧка
Две ВоБлы
ТуФЛи
Два ВеСла
Детская ФуФайка
оТВеРтка
ТуРНик
ДиРиЖабль
ТоРТ
ТаРаКан
ТРеЩотка
ТРуБа
ДРеЛь
ТРуСы
ДеРеВо
ТеРРорист
КаМиН
КНиГа
КоНДенсатор
КоНьКи
КуМаЧ
КНоПка
КаМыШ
КаНиСтра
КоНФета
КаМеРтон
КоЖаНка
Красная ЖиЖа
КоГоТь
КоЖуХ
число пи
КГБ
КеГЛя
Красивый ЖаСмин
три (3) ГВоздя
КоЖуРа
ХиТиН
Хот-ДоГ
КаТоД
ХоДиКи
КеТЧуп
КаТаПульта
КаТуШка
КуТуЗов
КаТаФалк
КаТеР
аККуМулятор
три (3) КеГли
КаКТус
КоКа-Кола
Компостная КуЧа
Красные КуБики
КуКЛа
КоКоС
Крепкий КоФе
аККоРдеон
ХиЩНик
три (3) ЧиЖа
КоЧеТ
КауЧуК
три (3) ЧуЧело
ХаЧаПури
КаЧеЛи
Калькулятор-ЧаСы
Крепкий ЧиФир
КоЧеРга
КаБиНа
три (3) БоГатыря
КиПяТильник
КаПКан
КаБаЧок
три (3) ПиПетки
КаПюШон
КаПСула
Кружка ПиВа
КоБуРа
КаЛеНдарь
КоЛГейт
КаЛиТка
КаЛьКулятор
КЛюЧи
ХЛеБ
КЛюШка
КЛиЗма
КЛеВер
КЛаРнет
КоСМетичка
три (3) СиГареты
КаСТрюля
КаСКа
КуСаЧки
Красная ЗиПпо
КоЗеЛ
КаССета
КуЗоВ
Коробочка СыРа
КоФейНик
Красный ФуЖер
КюВеТа
КВаКер
ХВоЩ
КоВБойка
КоВШ
КВаС
КоФеВарка
аКВаРель
КоРоНа
КРуЖка
КоРыТо
КРоКодил
КРюЧок
КРаБ
КРыШка
КРеСт
КРеВетка
КоРиЦа
Черная МиНа
Четыре НоГи
ЧеМоДан
ЩеНоК
Черный МяЧ
ЧеМПион
Четыре МеЛка
Черные НоСки
Черный НаВигатор
ЧайНиЦа
ЧуГуН
Четыре ЖГута
Черный ГуТалин
Четыре ГайКи
Четыре ЖуЧка
Черная ЖаБа
ЩеГоЛ
Черный ГуСь
Четыре ГВоздики
Чайный ГРиб
ЩеТиНа
Черный ДоГ
Четыре ДиоДа
ЧёТКи
ЩёТоЧка
Черный ДюБель
уЧиТеЛь
ЧуДеСа
ЧеснокоДаВка
ЧаДРа
ЧеКаНка
ЧиКаГо
ЧуКоТка
Четыре КаКтуса
ЧуКЧа
Черный КуБ
ЧеХоЛ
ЧеКиСт
ЧеХоВ
ЧаКРа
оЧеЧНик
оЧиЩенные оГурцы
ЧеЧеТка
ЩёЧКи
Ча-Ча-Ча
Четыре ЩеПки
ЧуЧеЛо
Четверть ЧаСа
оЧиЩенные Фрукты
Черный ЧеРеп
Черный БаНан
Черный БеГемот
ЩеПоТка
ЩеПКа
ЩиПЧики
Читальный аППарат
ЩуПаЛьце
ЧиПСы
ЧаПаеВ
ЧеБуРашка
ЧеЛНок
Чайная ЛоЖка
ЧаЛДа
ЧуЛКи
ЩеЛоЧь
ЩеЛБан
Черная ШеЛковица
ЧеЛюСть
ЧеЛоВек
Чугунный ШаР
ЧеСНок
Четыре СиГары
ЧаСТокол
ЧаСиКи
Черный СыЧ
ЧиЗБургер
ЧиСЛо
Чесночный СоуС
ЧаСоВня
Черный ЗаяЦ
Черный ФоНарь
Черная ФиГура
Чистая ВоДа
Черный ВыКлючатель
Чистые ВеЩи
Черный эФиоП
ЩаВеЛь
Черная ВиЗитка
Черные Вязаные Варежки
Черничное ВаРенье
ЧеРНила
Четыре РоГа
ЧеРТ
ЧиРКалка
ЧеРЧение
ЧеРеПаха
ЧеРеШня
Черная РоЗа
ЧеРВяк
яЩеРиЦа
БаНаН
ПиНГвин
ПоМиДор
БиНоКль
БаНоЧка
БоМБа
ПеНаЛ
ПеМЗа
БМВ
БуМеРанг
ПиЖаМа
БаГаЖник
БиГуДи
Пятнистый ЖуК
ПуГаЧ
Белая ЖаБа
ПуГаЛо
ПеГаС
ПуГоВица
аБаЖуР
ПауТиНа
ПиДЖак
ПоДДон
ПяТКа
ПяТаЧок
ПоДПора
БуТыЛка
ПоДСтаканник
ПаТеФон
ПуДРа
ПиКНик
БуХГалтерия
оБъеКТив
ПиККоло
Бессмертный КоЩей
ПиКаП
ПаКЛя
БоКС
БуКВы
БеКаР
ПеЧеНье
ПиЧуГа
ПеЧаТь
БаЧоК
Полосатое ЧуЧело
Белый ЧеБурек
ПЧеЛы
Полосатые ЧаСы
БеЧёВка
ПеЩеРа
БуБеН
ПоПуГай
ПиПеТка
ПаПКа
БаБоЧка
БаоБаБ
ПеПеЛьница
ПаПуаС
ПуПоВина
ПаПоРотник
ПаяЛьНик
ПЛуГ
ПаЛаТка
ПуШКа
ПаЛаЧ
ПоЛиП
БаЛаЛайка
ПЛаСтилин
ПоЛоВник
ПаЛеЦ
ПиСьМо
ПейЗаЖ
ПиСТолет
БаСКетбол
ПеСоЧница
ПаСПорт
ПьеЗоэЛемент
ПиССуар
ПоЗВоночник
ПуЗыРь
БиВеНь
Полосатый ВаГон
ПоВоДок
ПуФиК
Полоски оВоЩные
ПиВБар
ПаВЛин
ПоВяЗка
ПиВоВар
ПеВеЦ
ПиРаМида
ПРуЖина
ПРоТивогаз
ПаРиК
ПРиЩепка
БаРаБан
ПаРаШют
ПаРуС
БРеВно
ПеРеЦ
ЛиМоН
ЛиНГафон
ЛаНДыш
ЛиНейКа
Шипованный МяЧ
ЛаМПа
ШиНеЛь
аЛМаЗ
ЛеНиВец
ШНуРок
ШаГоМер
ЛеГкая Гирька
ЛоГоТип
ЛоЖКа
ЛеГоЧница
аЛГеБра
ЛяГуШка
ЛоГиСтика
ЛеГаВая
ЛаГеРь
ШТаНга
ЛеДоГенератор
ШТаТив
уЛиТКа
ЛоДоЧка
ШТоПор
ЛаДоШи
ЛоТоС
ШеДеВр
ШТуРвал
ШаХМаты
аЛКоГоль
ЛоКаТор
Широкая КойКа
ЛиХаЧ
ЛейКоПластырь
ШоКоЛад
эЛиКСир
ШКаФ
ШКуРка
ЛуЧиНа
ЛаЧуГа
эЛектрическая ЩеТка
ШаеЧКа
Лесная ЧаЩа
эЛектрический ЩуП
Широкая ЩеЛь
Люминесцентные ЧаСы
ЛеЧебная Вода
Ленточный ЧеРвь
аЛьБоМ
ШПаГа
ЛоПаТа
ЛоПуХ
ШаПоЧка
Школьная ПаПка
ШПиЛь
ЛоБЗик
ЛюБоВь
ШПРиц
ШЛеМ
ШЛаГбаум
ЛоШаДь
ШиШКа
Лазерный ЛуЧ
ШЛюПка
ШаШЛык
иЛЛюЗия
ШЛейФ
ШуЛеР
ЛеСеНка
ЛеЗГинка
ЛюСТра
ЛеСКа
ЛиСиЧка
Широкое СоПло
оЛовянный СоЛдатик
ЛаССо
ЛеЗВие
ЛаЗеР
ЛаВиНа
ШВейная иГла
ЛиФТ
ЛаВКа
ЛиФЧик
ШВаБра
ЛаВаШ
Широкая ВаЗа
Шоколадные ВаФли
ШиФР
ШаРНир
ШаРЖ
ШоРТы
ШаРиК
ЛаРЧик
ШуРуП
ШеРШень
ШеРСть
ШаРФ
Штанген-ЦиРкуль
оСьМиНог
СНеЖинка
ЗоНТ
СуМКа
СМыЧок
СоМБреро
СаМоЛет
ЗаМаЗка
СаМоВар
СМоРодина
ЗаЖиМ
ЗаЖиГалка
ЗаГоТовка
СайГаК
СГуЩенка
иЗГиБ
ЗаГЛушка
ЗаГС
ЗаГоВор
СиГаРеты
СТаНок
СТоГ
СТаТуэтка
СТаКан
ЗаТоЧка
СТоП
СТуЛ
СаДиСт
СТаВни
СТРекоза
СеКуНдомер
Старая ХиЖина
СКаТ
СКаКалка
СеКаЧ
СКоБа
СКаЛка
СаКСофон
СКоВорода
СКРипка
ЗайЧоНок
СыЧуГ
СЧеТы
СуЧоК
СЧетЧик
Соли ЩеПотка
ЗаЩеЛка
ЗубоЧиСтки
СоЧиВо
ЗаЧаРованные
ЗаПоНка
СаПоГи
СПуТник
аЗБуКа
СПиЧки
СуППорт
ЗуБиЛо
ЗаПиСка
СаПФир
ЗаБоР
СЛоН
ЗаЛоГ
СЛайД
СуШКа
иЗЛуЧатель
СаЛьПа
СуШиЛка
СиЛоС
СЛиВа
иЗоЛяЦия
СоСНа
Снежный СуГроб
ЗаСТежка
СоСКа
СоСоЧек
Золотые ЗуБы
СоСуЛьки
СоСиСки
ЗаСоВ
ЗаЗоР
ЗВоНок
оСВеЖитель
СВеТофор
СВеКла
СВеЧа
СВоБода
СуФЛе
СВиСток
ЗаВиВка
СВеРло
СиРеНа
СеРьГа
СеРДце
ЗеРКало
СоРоЧка
СеРП
оСЦиЛлограф
СРеЗ
СеРВант
Стационарная РаЦия
ВаННа
ВиНоГрад
ВеНТилятор
ВеНиК
ВеНЧик
ВаМПир
ФиНиШ
ВНиЗ
ФаНФара
ФоНаРь
ВаГоНетка
ВыЖиГатель
ФаГоТ
Винт с ГайКой
коФейная ГуЩа
Винный ЖБан
Вареный ЖеЛток
ФуГаС
ВиГВам
ФиГуРы
аВТоМат
ФоТоГрафия
ФоТоТаймер
аВТоКар
ВеТоЧка
ФуТБолка
ФуТЛяр
Виниловый ДиСк
Фруктовый ТВорожок
ВеДРо
ФотоКаМера
8 кг
ВыХоД
Воздушная КуКуруза
Высокие КаЧели
Вельветовая КеПка
ФаКеЛ
ФоКуС
Вязаная КоФта
ВаКЦина
Фарфоровый ЧайНик
ВеЧный оГонь
ВеЧный Двигатель
оВеЧКа
Филина ЧуЧело
Фигурные ЧиПсы
Вязаный ЧуЛок
оВоЩеСушилка
Вареный ЩаВель
оВоЩеРезка
ФотоБуМага
Вязаная ПуГовица
Велосипедная ПеДаль
Винни-ПуХ
ВыПеЧка
ФотоаППарат
ФотоПЛенка
ВыПиСка
Высокий ПуФик
ФБР
ВоЛаН
ФЛаГ
ФиЛьТр
ВаЛиК
ВоЛЧок
ФотоаЛьБом
ВеШаЛка
ВеЛоСипед
ВоЛьВо
Воздушный ШаР
ВаЗоН
оВСюГ
ВъеЗД
ФиЗиКа
ВаЗоЧка
ВСПышка
ФаСоЛь
ФоССа
ФоСФор
ВиЗиР
Виноградное ВиНо
Восковая ФиГура
Воздушная ВаТа
ВыВиХ
Вареные оВоЩи
Вяленая ВоБла
ВаФеЛьница
ВыВеСка
три восьмерки
ВВЦ
ФаРаоН
ФуРаЖка
ВеРТолет
аФРиКа
ВРаЧ
ВеРБлюд
ФаРШ
ФеРЗь
ВеРеВка
аВРоРа
РеМеНь
РиНГ
аРМаТура
РаМКа
РаНЧо
РоМБ
РоМаШка
оРужейное МаСло
ЦиНоВка
РаНеЦ
аРГаМак
РоГоЖа
РоГаТка
РоЖоК
РоГаЧ
РеГБи
иеРоГЛиф
ленин
РЖаВчина
РоЖиЦа
оРДеН
РаДуГа
РаДиаТор
РеДьКа
РадиоТоЧка
Резиновая ДуБинка
РеТуШь
РеДиСка
аРТеФакт
РаДаР
РуКоМойник
Рваная КоЖа
РаКеТа
оРеХоКол
Розовые КаЧели
РуКоПись
ЦиКЛя
РюКЗак
РаКоВина
РеКоРд
РуЧНой (эспандер)
РыЧаГ
Резиновая ЩеТка
РуЧКа
Румяные ЩеЧки
Розовый ЧеПчик
Русская ЧаШа
РадиоЧаСы
РуЧной Фонарик
РуЧной Радар
РуБаНок
Рукав ПоЖарный
РоБоТ
РыБКа
РяБЧик
Ром-БаБа
аРБаЛет
аРБуЗ
Разливное ПиВо
РуПоР
ЦиЛиНдр
Цветочный ЛуГ
РуЛеТка
РоЛиКи
Цилиндр и ЛиЧинка
РаШПиль
Резиновый ШЛанг
РеЛьСы
РеЛьеФ
Розовый ШаРик
РеСНицы
РоЗГи
РоЗеТка
иРиСКи
РоЗоЧка
РеСПиратор
РуСаЛка
РеЗиСтор
РейСФедер
РеЗеЦ
РеВуН
Цветные ФиГуры
ЦВеТок
РаФиК
Розовая оВЧина
РиФленая Бумага
РеФЛектор
Цифровые ВеСы
ЦВетной Фартук
ЦиФеРблат
оРанжевая уРНа
оРанжевая оРиГами
аРаРаТ
ЦиРКуль
Цветные РуЧки
РеЦеПт
РоРШах
Ржавая ЦиСтерна
ЦаРеВна
РыЦаРь
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}