using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/InstrId/([^/]{1,16}).*/$";
string input = @"/InstrId/20230222130245970/ /EndToEndId/REF 2102231XX4/ /BICFI/XXXXXRAAXXX/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}