$re = '`^/InstrId/([^/]{1,16}).*/$`m';
$str = '/InstrId/20230222130245970/ /EndToEndId/REF 2102231XX4/ /BICFI/XXXXXRAAXXX/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);