$re = '/\A([^!]*)[!]{1}\Z/';
$str = 'My string here!
My string here!!
My string here!!!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);