re = /\A([^!]*)[!]{1}\Z/
str = 'My string here!
My string here!!
My string here!!!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end