$re = '/(?i)(?<=SomeValue=\').*?(?=\')/m';
$str = 'SomeValue=\'String2Find\'
SomeValue =\'String2Find\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);