re = /(?i)(?<=SomeValue=').*?(?=')/m
str = 'SomeValue=\'String2Find\'
SomeValue =\'String2Find\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end