package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)apple[\s\S]+^(his)`)
var str = `apple
his
apple his
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}