$re = '/apple[\s\S]+^(his)/m';
$str = 'apple
his
apple his
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);