using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From:.*\K\b[_a-z0-9-]+(?:\.[_a-z0-9-]+)*@[a-z0-9-]+(?:\.[a-z0-9-]+)*\.[a-z]{2,4}\b";
string input = @"From: Name email@email.co.uk mailto:Name@email.co.uk text text text";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}