re = /From:.*\K\b[_a-z0-9-]+(?:\.[_a-z0-9-]+)*@[a-z0-9-]+(?:\.[a-z0-9-]+)*\.[a-z]{2,4}\b/mi
str = 'From: Name email@email.co.uk mailto:Name@email.co.uk text text text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end