using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(public|private|protected|static|final|abstract|synchronized|volatile)\s*([\w<>\[\]]+)\s*(\w+)\s*\(([\w\s\w,<>\[\]]*)?\)\s*(\bthrows\b)?[\s\w\s,\w]*\{[\n\t]*(.+)[\n\t]*((return|throw){1}\s*)(\w*)\s*;\s*[\}]";
string substitution = @"";
string input = @"public boolean test(String fsdfds)
{
boolean boolean = Service.GLP.equals(somevariable.getserviceType());
return boolean;
}
public static String replaceContentOfFile(String fileContent, String regex, String replace) {
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(fileContent);
final String result = matcher.replaceAll(replace);
return result;
}
public boolean test2(String fsdfds)
{
boolean boolean = Service.GLP.equals(somevariable.getserviceType());
return boolean;
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}